SaveAs Excel memo zip- help?!

  1. I am amazed by how flexible, fast and smooth GS-Base is!
  2. The ‘forum rules’ I’m supposed to read before posting give a ‘file not found’ message.
  3. I have been unable to figure out my error when saving a dBaseIII+ origin database-with-memos (DBF and DBT files) as Excel. GS-BASE shows the memo content in its memo-field panel just fine. However, when I ‘save as Excel’- I can find no sign of the .ZIP file that is supposed to be holding the memo entries in a next of folders. The Excel output clearly includes references links to the hoped-for content. But the expected ZIP file is not located in any oplace I could discover it.

I have tried several variations of saving, including saving into native GS-Base format before saving to Excel. I have also tried the per-memo button to save ast text. Neither of those has worked for me. The source files (developed in FoxPro, but open properly only using the dBase III+ or Clipper formats.

I need to recover the original memo contents. If the Excel export is the only way- I truly hope someone can walk me through the proper way to do it.
If other methods exist- please feel free to share.

Excellent work on this really surprisingly good database product!


Thanks. You should select the “split 64k+ row tables using into files (…)” xls saving option. It was the default one (and only) in the previous versions.

However, you can also download the version 18.2.4 where saving xls files with linked binary contents has already been enabled for the other two newly added xls saving options.

Thanks- my 8.2.1 does the exports as described.
I can’t find the magic to get the 8.2.4 download, but would like to get it.

Sadly, it looks like my FoxPro memo fields are a trashy accumulation. I see that FoxPro’s memo file format was so simple it became undecipherable. Apparently all new AND all edited records got written to the END of the file- with prior versions left intact above. Indexing to the memo seems to have relied entirely on the pointer preserved in the DBF file. I suspect I’m now finding the valid START of a memo but followed by unknown other later entries, probably from other records. Uck.

If anyone has had success recovering FoxPro memos, I would love to hear anything you have learned about how you did it!


You can download GS-Base 18.2.4 or newer clicking any GS-Base 64-bit download link.

If it’s strictly the FoxPro fpt memo file then you should use the “FoxPro 2.x” option in GS-Base, unless this is some newer modification. The “Clipper” option might also be sufficient, but not dBaseIII+. If you see some trailing garbage in loaded memos, then the formats don’t match.