Bug in fnd and replace v.15

I am using GS-Calc v. 15, 64 bit in Windows 7 Ultimate. I copied a calculated column of numbers and pasted w/o formula to a new worksheet so they would be standalone. Using find and replace to change some values, I found replacing 2 with 0 resulted in every number that contained a 2 turned into a 0, e.g. 23 became 3. I have the options set to exact matching (Plain text full content matching). Using find only it will skip over the 23 and only find the 2s.

I tried this in a new workbook manually typing in numbers and it did the same thing. I also tried replacing the 3s and 4s and the same thing happened.

I tried this on my laptop with v. 16 trial and the bug was not present, so I’m going to have to upgrade.

Another suggestion: Make newer versions backwards-compatible. I can’t open the v. 16 file I created on my laptop.

As usual, thanks for reporting found issues. Yes, there was some update re: the “full content” matching option in the past.
Regarding the backward compatibility, to open 16. files in 15. you have to use the Open Document *.ods format. The binary *.gsc format is typically optimized (to achieve the highest possible loading/saving speed) after each major version update which means always a newer version is required to use it.